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1.  Introduction 
 
Welcome to ChattyInfty!  ChattyInfty is a mathematical document editor to provide a user 
with speech-output access while reading, editing or authoring math/scientific documents.  
Furthermore, since this new version, "ChattyInfty, Ver.3 (ChattyInfty3)" has many new features 
such as DAISY/accessible-EPUB3 output capability, you can produce various types of 
accessible    e-books with it. 
 
This software has been developed by "the InftyProject" and "the Non-Profit Organization: 
Science Accessibility Net (sAccessNet)."  Our organizations also offer other software and 
many services to help print-disabled people with accessing math/scientific information.  
Please visit our web site: http://www.sciaccess.net/en/index.html 
For more detailed information. 

1.1  Original Features of ChattyInfty 

* Math expressions or scientific documents ranging from secondary education to higher 
education levels can be written or edited by using the keyboard with speech output. 

* Files made with ChattyInfty can be saved in various accessible formats: LaTeX, MathML, 
PDF, HTML or Microsoft Word XML.  An original format: IML (Infty Markup Language) 
is essentially XML and is completely compatible with other Infty software: the math OCR 
software, "InftyReader" and the Math-document editor for sighted people, "InftyEditor." 

* Information displayed on the main window of ChattyInfty is completely equivalent to that of 
InftyEditor.  All of math expressions are displayed in the ordinary print style.  ChattyInfty 
reads aloud not only texts but also those math expressions.  Print-disabled students can 
access, edit or author math/scientific documents including math expressions with speech 
output.  They, therefore, can share the same educational materials with their sighted 
classmates.  Their teachers can easily prepare those materials by making effective use of 
InftyReader and InftyEditor.  Furthermore, the teachers can directly read documents that 
visually disabled students draw up even if they are not familiar with Braille. 
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1.2  What’s New in ChattyInfty3 

* In ChattyInfty3, Multimedia DAISY and accessible EPUB3 is officially adopted as output 
format.  In the accordance with this improvement, we upgraded thoroughly software itself.  
Thus, it becomes also useful for people with low vision or dyslexia.  In the software, as for 
the previous version, a blind user can read and author mathematical documents with speech 
output.  A low-vision reader can improve contrast or magnify the displayed content for ease 
of reading.  Visual tracking and synchronized speech allow a dyslexic reader to maintain 
focus on a document. 

* Since a result recognized by InftyReader can be imported directly, both the sighted and print-
disabled can produce mathematical DAISY (accessible EPUB3) books easily from 
printed/PDF materials by making use of only Infty software.  ChattyInfty3 is very useful as 
authoring tools to produce accessible e-books. 

1.3  System Requirements 

The operating system should be either Windows 7 or later.  The Microsoft Internet Explorer 9 
or later must be installed.  Microsoft speech API version 5 must be installed. 
 
 
2.  Installation and Activation 
 
Perform setting.exe in the ChattyInfty3 folder and follow the instructions.  You have to select 
a language used in the installation process.  It will be also a default language in the software.  
After installation, you will be asked to complete an online activation.  You can find more 
detailed information about them on our web site: 
 http://www.sciaccess.net/en/. 
 
 
3.  Getting Started 

3.1  How to Input 

The window of ChattyInfty3 is divided into two parts: an index window and a main window, in 
a similar way to other popular DAISY browsers.  The index window has a tree structure to 
show a table of contents in a style similar to that of Windows Explorer.  This gives a user 
random access to a document displayed in the main window.  Pressing the F6 or the Ctrl + F6 
key, one can easily switch the active window.  Otherwise, by pressing the Enter key at a certain 
entry in the index window, the cursor moves to a corresponding position in the main window. 
 
Remark: 
If the other windows were opened such as the Last Reading bar, pressing the F6 or the Ctrl + 
F6 key would get the cursor to move among all of them one by one. 
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In order to input something in a document, at first, you have to move to the main window.  
When starting the software, the cursor is located at the heading in the index window.  At that 
time, ChattyInfty says "Index level 1. Input title, here."  By pressing the Enter key, it moves 
to the first line of the main window.  Since the first line is regarded automatically as the 
heading; that is, the statement: "Input title, here" is a default heading that is written in the first 
line.  You can change it as you like; then, top of the index window will be changed 
automatically.  Please input a content from the next line to it. 
 
In the main window, ChattyInfty3 is started with "Text (input) mode."  In this mode, you can 
write or edit literary texts with the keyboard.  To input math expressions, press the Ctrl + the 
Space key to switch to the "Math (input) mode."  By using this key stroke, you can switch 
between the Text and the Math input modes alternately. 
 
Remark: 
You can change this shortcut to switch them, using setting menu. 

3.2  Using Math Input Mode 

To input characters or symbols which are not on the keyboard, ChattyInfty provides two 
methods as follows: 
 
3.2.1  Keyboard-based input method 
Enter "¥" followed by a specific name (a TeX command) and convert it with the Space key or 
the Enter key.  Then, a math symbol corresponding to the command is input at the cursor 
position.  For instance, if you want to input Greek letter alpha, enter ¥alpha with keyboard and 
then press the Space (or the Enter) key.  When you start inputting the command, the list of 
candidates that have the same initial letters is displayed; so, you can choose an appropriate one 
in it. 
 
3.2.2  Menu-operation-based input method 
Select from the Context menu that pops up by pressing the Application key (or right click).  
More detailed instructions for it will be given later. 
 
Up to five Characters/symbols recently selected are displayed in the Context menu.  It may be 
convenient when you want to input same things repeatedly.  See "Input reference" (List of 
characters and symbols) in the Help menu for the character/symbol commands and their 
classification.  
 
Other than Math-mode symbols, special characters such as extended Latin character sets in Text 
mode are also available with the symbol lists that pops up by pressing the Application key (or 
right click). 
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3.3  Creating Math Formulas 

3.3.1  Superscript and Subscript 
ChattyInfty provides an intuitive manner to input various math formulas.  For instance, 
super/subscripts can be written in the following way. 
 
Example1: Superscript/Power 
To write an x squared, do the following: 

1.  Type the base letter, "x". 
2.  Press the Up Arrow key or Input ^ (hat).  The cursor will move to the superscript 

position, and ChattyInfty will say "power." 
3.  Type the 2 and press the Enter key.  The cursor will return to the base line. 

 
Example2: Subscript 
To write a x with a subscript, n, do the following: 

1.  Type the base letter, "x". 
2.  Press the Down Arrow key or _ (Under-bar).  The cursor will move to the subscript 

position, and ChattyInfty will say "sub." 
3.  Type the "n" and press the Enter key.  The cursor will return to the base line. 

 
Remark: 
Using the setting menu, you can change the setting so that, instead of the Up/Down arrow keys, 
the Ctrl + Up/Down arrow keys moves the cursor to the super/subscript position.  At that time, 
the Up/Down arrow key simply moves the cursor to the previous/next line. 
 
3.3.2  Inputting Special Characters 
As was mentioned previously, math characters that are not on the keyboard can be input from 
the Context menu that pops up by pressing the Application key on the keyboard.  It also 
appears by pressing the Shift plus F10 or right-clicking the mouse.  In the Character/Symbol 
set, there is a list of many special characters/symbols.  Some examples are shown below. 
 
Example1: 
To write a Greek letter, alpha, do the following: 

1.  Press the Application key to open the Context menu.  ChattyInfty says "Context menu." 
2.  Press the Down Arrow key several times to find an item, "Character, Symbol." 
3.  Press the Right Arrow key to move to the submenu; then, ChattyInfty says "Greek." 
4.  Press the Right Arrow key to move to the entry list of the Greek letters. 
5.  Select alpha and press the Enter key.  Be sure that the entry list begins with capital 

letters. 
 
Example2: 
To write a symbol of "is greater than or equal to", do the following: 
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1.  Press the Application key to open the Context menu.  ChattyInfty says "Context menu." 
2.  Press the Down Arrow key several times to find the item, "Character, Symbol." 
3.  Press the Right Arrow key to move to the submenu. 
4.  Press the Down Arrow key to find an item, "Relative Symbol." 
5.  Press the Right Arrow key to move to the entry list of the relative Symbols. 
6.  Select the symbol of "is greater than or equal to" and press the Enter key. 

 
3.3.3  Math Syntax 
Besides the superscript and the subscript, there are many special notations in mathematics.  We 
call them "Mathematical syntaxes."  They can be also input from the Context menu.  To input 
characters/symbols in a place other than a base line such as a fraction made of a denominator 
and a numerator, a radical in which characters and symbols are written in certain layout or other 
math syntax with super/subscript around symbols (a summation, for instance), the following 
two methods are provided. 
 
A.  Keyboard-based Input Method 
First, enter ¥ followed by a certain syntax name (a TeX command) and press the space (or the 
Enter) key.  Then, an empty syntax is input at the original cursor position, and the cursor 
moves to inside of it automatically.  You can enter characters and symbols in it to make up a 
formula.  If you need to enter super/subscript area in the syntax (the index in radicals, for 
instance), press the right/Left Arrow keys after entering the base characters; then, the cursor 
moves to the positions that need to be input. 
 
B.  Menu-Operation-based Input Method 
Select the syntax from the Context menu that pops up by pressing the Application key (or the 
right click).  Then, an empty syntax is input at the original cursor position, and the cursor 
moves to inside of it.  You can enter characters and symbols in it to make up a formula. 
 
You can refer to "Input quick reference" (Mathematical Syntax List) in the Help menu to check 
each command and input method. 
 
Example1: 
To write the fraction, "one over two" do the following: 

1.  Press the Application key to open the Context menu.  ChattyInfty says "Context menu." 
2.  Press the Down Arrow key several times to find an item, "Formulas." 
3.  Press the Right Arrow key to move to the submenu.  ChattyInfty says "Frac." 
4.  Press the Enter key.  An empty fraction is placed at the original position of cursor.  The 

cursor moves to its numerator position automatically.  ChattyInfty says "Numerator." 
* Instead of the steps 1-4, you can do the same thing by inputting ¥frac (or simply ¥f) and 

pressing the Enter key. 
5.  Type "1" and press the Right Arrow key to move the cursor to the denominator position.  
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ChattyInfty says "Denominator." 
6.  Type "2" and press the Right Arrow key and the cursor will move out of the fraction to 

the next position on the base line. 
 
Remark: 
Pressing the Enter key also moves the cursor to the denominator position or outside of the 
fraction; however, no messages will be spoken. 
 
Example2: 
To write the square root of 2, do the following: 

1.  Press the Application key to open the Context menu.  ChattyInfty says "Context menu." 
2.  Press the Down Arrow key several times to find the item, "Formulas." 
3.  Press the Right Arrow key to move to the submenu. 
4.  Press the Down Arrow key once; then, ChattyInfty says "Square Root." 
5.  Press the Enter key.  An empty radical is inserted at the original position of cursor.  

The cursor is located inside the radical.  ChattyInfty will say "Inside Radical." 
* Or you may input ¥sqrt (or simply¥r) and press the Enter key, instead of the steps 1 - 5. 
6.  Type "2" and press the Right Arrow key to get out of the radical. 

 
Remark: 
If you want to input a general radical, you may use another command: "Radical."  Be sure that 
radicals in ChattyInfty have three areas: the radical index area, a main area and a superscript 
area, or the power for the entire radical.  Using the Context menu, you can write many of other 
special mathematical notations. 
 
3.3.4  Other keyboard shortcuts 
Here, some other keyboard shortcuts to input math syntaxes are shown below. 
 
* Summation-Type syntax: 

Those syntaxes are listed in "Formula with Under and Over Areas" in the Context menu. 
For Instance, in terms of the summation, instead, you may input ¥sum (or simply ¥s). 

* Limit-Type syntax: 
They are listed in the "Formula with Under Area." 
For the limit, you may input ¥lim. 

* Integral-type Syntax: 
They are listed in "Integral." 
Otherwise, input ¥int (or simply ¥i). 

* Accent Mark: 
They are listed in "Accent." 
For instance, in terms of drawing a overline, input ¥overline. 
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Note: Extended Latin letters in text area (e.g. accent and cedilla of French) are not assumed as 
the accent marks in mathematical syntax in the Math mode.  They can be displayed in font as 
Latin letters in text mode.  Also, accent marks for math expressions do not work in the text 
mode. 
(See the Symbol list of Latin 1 and Latin 2 in the Context menu.) 
 
* Matrix-type syntax: 

A matrix-type syntax cannot be input with the Context menu.  A manner to input big (multi-
line) enclosing symbols for matrices, simultaneous equations and so on is as follows: 
Input ¥ followed by one of [, {, (, |, || from the keyboard.  By pressing the Enter key, an 
empty matrix-type formula enclosed with the indicated symbols is input at the cursor position.  
The cursor moves to inside of it, automatically. 

 
Remark: 
If the closing symbol is not necessary (in the case of Simultaneous equations, for instance), 
press the Right Arrow key after completing to enter the content, to let the cursor move to the 
position just in front of the closing symbol.  (At that time, the cursor is located at the same 
height as the closing symbol.)  Then, delete the closing symbol with the Delete key. 
 
The width and length of the enclosed area is automatically adjusted depending on the size of 
content; however, the elements are not aligned automatically.  You need to align them 
manually for yourself by using spaces or tabs. 
 
3.3.5  Table 
In the previous version of ChattyInfty, a table should be authored in a different pop-up window 
that was not necessarily accessible enough.  On the other hand, it can be directly authored in 
the ChattyInfty3 main window. 
 
Pressing the Ctrl + the Shift + T or Performing "Insert Table" command in the Edit menu, users 
get into a dialog to create a new table.  The numbers of columns and rows can be chosen freely.  
By pressing OK button, an empty table of the specified size is inserted at the cursor position of 
an original document.  In addition, a given (simple) table in Microsoft Excel can be cut out 
and pasted into a ChattyInfty3 document via Windows Clipboard. 
 
Remark: 
A format specified in Microsoft Excel such as combining cells, however, would not be 
necessarily preserved with this operation. 
 
In terms of browsing in a table with speech output, users can do it with usual cursor and tab 
operations.  The cursor moves character by character inside the cell with the Left/Right key.  
It, however, would go to the next cell with the same operations if it were located at the top/end 
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of the item in the cell.  Tab/Shift + Tab or Ctrl + Left/Right Arrow keys can also change the 
cursor location to the next cell.  You can move the cursor vertically with the Up/Down Arrow 
key.  Thus, print-disabled people can read it cell by cell horizontally or vertically as they like.  
Technical content of each cell is read out in the ordinary manner of ChattyInfty. 
 
In addition, when reading aloud a table, ChattyInfty says the address of a cell first and then, 
reads out its content.  In the default setting, the address is represented as "A2" that means "the 
column A and the row 2."  As will be explained later, by editing ReadSetting_SAPI5_en.txt, 
users could change how to express the address in speech if necessary. 
 
Print-disabled people can edit the content of a table in an intuitive manner.  Any formulas or 
texts can be input in a table cell in the ordinary method of ChattyInfty.  Furthermore, by 
pressing the Application key (or right-clicking) inside the table, various special commands to 
modify table style such as adding a column can be done.  The "Table Setting" command in the 
context menu allows users to get into the table editor.  Using the table editor, they could 
customize the table layout more flexibly if necessary. 
 
The following shortcuts are also available in the table environment. 
 Shift + Enter  Adding a new column under the current cell 
 Ctrl + Shift + Enter Adding a new row at the right of the current cell 
(When adding a column or a row, the cursor moves automatically to the new position.) 
 Shift + Del  Deleting a column at the current cell 
 Ctrl + Shift + Del Deleting a row at the current cell 
 
Remark: 
However, a column or a row could not be deleted if their number became less than one with 
that operation. 
 
The flush-left, centering or flush-right shortcuts such as Ctrl + L are also available even in the 
table cell to change the horizontal position of an item in the cell.  Their vertical position in the 
cell can be also customized with the table editor. 
 
3.3.6  Inserting Figures and Other images 
ChattyInfty, itself has no functionality to draw/edit a figure.  However, you can embed an 
tiff/jpg image file into it.  For instance, you can cut out a figure as an image from a PDF file 
and paste it in ChattyInfty.  At that time, the resolution the image should be set 600DPI. 

3.4  How to Input from Math OCR 

Using ChattyInfty, people with print disabilities can access math/scientific documents in print 
or PDF including math expressions.  In order to use this function, you need to install our math 
OCR system named "InftyReader, Ver. 3 series (InftyReader3)" as well.  Since it can recognize 
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not only special characters but also various technical notations such as a fraction, a radical etc. 
and export the results into ChattyInfty, you can access or edit them with speech output. 
 
3.4.1  What Is InftyReader? 
InftyReader is OCR software for scientific documents, which was also developed and provided 
by sAccessNet.  InftyReader recognizes scanned page images of English documents including 
math expressions.  From each page image, figure areas, table areas and text areas are 
segmented automatically. 
 
Download site of InftyReader is:  
 http://www.sciaccess.net/en/. 
 
3.4.2  System Requirements 
InftyReader runs on Windows7 or later. 
 
3.4.3  Language 
The current version (English edition) can recognize only printed/PDF documents in English.  
Be aware that it does not recognize Japanese characters at all.  However, combining 
InftyReader with the FineReader Plug-in, it becomes able to recognize other many European 
languages using extended Latin characters.  Please look at our web site: 
 http://www.sciaccess.net/en/ 
for more detailed information about this point. 
 
See the manual of InftyReader for more detailed information.  You can also perform OCR 
from the menu of ChattyInfty.  At that case, you may use "Import" in the File menu. 
 
3.4.4  How to Use the Sheet View Window 
When the recognized result is displayed on the main frame of ChattyInfty, the "Sheet View 
window" pops up to show the original page image.  Since the original scanned image that 
exactly corresponds to an area around the cursor position is displayed, sighted people can easily 
check any errors of the recognition. 
 
It is remarkable that information on the Sheet View window is also available for visually 
disabled people.  By pressing F4 key, the focus moves to the Sheet View window.  If you had 
a certain sophisticated tactile-graphic tool such as View Plus embossers, you could output the 
image directly from this window as tactile graphics.  So, even if you were totally blind, you 
could grasp and correct recognition errors for yourself with the tactile graphics.  Printing the 
Sheet View window is supposed to be done from the own File menu of this special window.  
The focus will be back to the main window when you move the cursor with Arrow keys. 
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4.  Speech Output and Speech Setting 

4.1  Speech Engine 

Since ChattyInfty uses Microsoft speech API (SAPI), the version 5 as the speech engine, it must 
be installed.  If a SAPI5 voice is already installed, ChattyInfty will speak automatically when 
it is started. 
 
Remark: 
If a SAPI5 voice were not available in your local language, ChattyInfty3 could not read out 
contents.  Even in such a case, however, if a voice of "Windows10 OneCore" or "Microsoft 
Speech Platform" were available, you could use it as a SAPI5 voice.  Concerning this point, 
please read "SpeechFiveMagic.docx" included in: 
 C:¥Program Files (x86)¥sAccessNet¥ChattyInfty3¥lang¥documents,  
or see the web site:  
 http://www.digitalnauts.co.jp/sfm/?lang=en. 
 

4.2  Reading Aloud 

ChattyInfty reads aloud texts and also math expressions.  You can access, write or edit 
scientific documents including math expressions with speech output. 
 
4.2.1  Reading of Text 
In the text part of the document, operations concerning aloud reading are almost same as other 
screen readers.  When the cursor is moved to the next or previous line with the Down or Up 
Arrow key, ChattyInfty reads aloud the content of line from the beginning to the end.  When 
the cursor is moved to right or left, ChattyInfty reads aloud the one character that is just located 
at the right hand side of the cursor.  You can read the text in a word-by-word manner by 
pressing Ctrl + the Right/Left Arrow key. 
 
Remark: 
By using "Read Out" menu, ChattyInfty reads out automatically an indicated part of document 
without cursor operations.  At that time, the cursor keeps its original position. 
 
By pressing Ctrl + F1 key, you can hear a line number where the cursor is currently located. 
 
Using the "Speech Setting" in Setting menu, you can change the kind of SAPI5 voices, their 
pitch and speaking rate.  The voices and pitches for the text and math parts could be different 
from each other. 
 
4.2.2  Reading of Math Expressions 
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You can also browse a math expression with the cursor operations; however, you should be 
careful because the behavior of cursor when pressing Arrow keys is different from that in text.  
For instance, if you pressed the Up Arrow key, the cursor would move to its superscript position, 
not to the previous line.  To move to the previous line, you need to press Ctrl + the Up Arrow 
key.  Also to move the cursor to the next line in the math expression, you need to press Ctrl + 
the Down Arrow key.  If you find this confusing, this function can be changed so that the Ctrl 
+ Up/Down arrow key moves the cursor to the super/subscript position.  In this case, the cursor 
goes simply to the previous/next line by pressing the Up/Down key only. 
 
 
Remark: 
As was mentioned previously, by using "Read Out" menu, ChattyInfty reads out automatically 
math expressions without cursor operations.  At that time, the cursor keeps its original position. 
 
4.2.3  Details about Reading Math Expressions Aloud 
ChattyInfty has a defined way to read aloud each math symbol.  They are classified into 
several groups and listed in the Context menu.  If necessary, this defined way of aloud reading 
can be changed in the Setting menu described later in this manual. 
 
Corresponding to various types of the print disabled, their demands or necessities, we provide 
three types of aloud reading for math formulas.  "How a math formula should be read aloud" 
does depend on the characteristics of the reader’s disability.  For blind users, extra messages 
for which there are no corresponding print symbols explicitly in a math formula should be 
provided to show the structure of that formula exactly.  For instance, they do need messages 
such as "Begin Fraction" and "End Fraction."  The manner of "aloud reading" originally 
defined in ChattyInfty was essentially of this style.  However, for other print-disabled people 
who can "see" the math expression up to a certain level, dyslexic users for instance, those extra 
messages actually disturb their understanding.  They are often confused with the messages 
that do not have corresponding print symbols.  Furthermore, even for blind users, when 
reading material repeatedly, they tend to want to skip those messages as well. 
 
Thus, we implemented a new function in ChattyInfty3 so that three different types of "aloud 
reading" for math syntaxes can be selected.  "Plain-Reading mode" is based on one which may 
be most widely used in English-speaking countries.  It is natural; however, a spoken math 
expression is often ambiguous.  We assume that people with low vision and dyslexia use it.  
In "Smooth-Reading mode," minimum-necessary speech guides for blind users to grasp the 
structure of a math formula correctly are added.  "Detailed-Reading mode" is assumed to be 
used when a blind user wants to know the math-formula structure in the most detail.  Pressing 
Ctrl + F5 key switches these three modes; or you can also change the mode in the Setting menu. 
 
In terms of math symbols, as same as the previous version, each of them is assigned two 
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different manners of aloud reading: the Plain reading and the Detailed reading.  In the Detailed 
Reading, all of the character's attributes such as "capital" are read aloud.  Those two modes 
are applied in the Plain/Smooth Reading mode and in the Detailed Reading mode, respectively.  
That is, the manner of aloud-reading math symbols in the Smooth Reading mode is as same as 
the Plain Reading mode. 
 
Here are some examples of aloud reading of math formulas in the Smooth Reading mode that 
is default in ChattyInfty3. 
 
 
Example1: Superscript/Power (1) 
"x squared" is read aloud in these ways: 

a. When reading it straight through, it is "x squared" 
b. When reading it character by character from beginning to end, it is "x power 2, end power" 
c. When reading it character by character from end to beginning, "power 2, left super, x" 

 
Here, "left super" indicates a superscript area on the left hand side of x.  This area is skipped 
in the case b.  If there were letters in this area, they would be read with a rising intonation 
before the base character in the case a. 
 
Example2: Superscript/Power (2) 
"e to the i theta power" is 

a. When reading it straight through, "e to the i theta power" 
b. When reading it character by character from the beginning to the end, "e, power i, theta, 

end power" 
c. When reading it character by character from end to beginning, "power, theta, i, left super, 

e" 
 
Example3: Subscript 
"x with the subscript n" is read aloud in these ways: 

a. When reading it straight through, " x sub n"  
b. When reading it character by character from beginning to end, "x, sub n, end sub." 
c. When reading it character by character from end to beginning, "sub, n, left sub, x" 

 
Here, "left sub" indicates a subscript area on the left hand side of x.  This area is skipped in 
the case b.  If there were letters in this area, they would be read with the rising intonation 
before the base character in the case a. 
 
Example4: Fraction 
Fraction, a plus b over c is read aloud in the following ways: 

a. When reading it straight through, "frac a+b over c" 
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b. When reading it character by character from beginning to end, "frac, numerator a, plus b, 
end numerator, denominator c, end denominator" 

c. When reading it character by character from end to beginning, "denominator, c, numerator, 
b, plus, a, frac" 

 
Example5: Simple Radical 
The square root of 2 is read aloud in these ways: 

a. When reading it straight through, "square root of 2" 
b. When reading it character by character from beginning to end, "radical, inside radical 2, 

end inside radical." 
c. When reading it character by character from end to beginning, "inside radical, 2, radical" 

 
Example6: General Radical 
The nth root of a is 

a. When reading it straight through, "index n root of a" 
b. When reading it character by character from beginning to end, "radical, radical index n, 

end radical index, inside radical a, end inside radical." 
c. When reading it character by character from end to the beginning, "inside radical, a, radical 

index, n, radical" 
 
Example7: Special Symbols with Superscript and/or Subscript (1) 
A summation from k=1 to n is read aloud in the following ways: 

a. When reading it straight through, "summation from k=1 to n of" 
b. When reading it character by character from beginning to end, "summation, under k, =, 1, 

end under, over n, end over" 
c. When reading it character by character from end to beginning, "over, n, under, 1, =, k, 

summation" 
 
Example8: Special Symbols with Superscript and/or Subscript (2) 
An integral from a to b is read aloud in the following ways: 

a. When reading it straight through, "integral from a to b of" 
b. When reading it character by character from beginning to end, "integral, sub, a, end sub, 

super, b, end super" 
c. When reading it character by character from end to beginning, "super, b, sub, a, integral" 

 
Example9: Special Symbols with Superscript and/or Subscript (3) 
A limit of x approaching 0 is read aloud in the following ways: 

a. When reading it straight through, "limit as x right-pointing Arrow 0 of." 
b. When reading it character by character from beginning top to end, "limit, under, x, right-

pointing Arrow, 0, end under." 
c. When reading it character by character from end to beginning, "under, 0, right-pointing 
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Arrow, x, limit" 
 
Example10: Matrix 
A 2 times 2 matrix enclosed with parentheses is read aloud in the following ways: 

a. When reading it straight through, "left paren, line of 1 a b, line of 2 c d, right paren" 
b. When reading it character by character from beginning to end, "left paren, a, b, new line, 

c, d, new line, right paren" 
 
The message "new line" indicates a special line break in the array representation.  You can 
move the cursor not only horizontally but also vertically in the matrix to browse it. 

4.3  Speech Setting and Related Commands 

Some commands in the Setting menu allow users to customize the setting concerning speech 
output. 
 
4.3.1  Voice Setting 
If several kinds of SAPI5 voices were installed in your PC, you could change the default voice 
for each of a text and math parts with the "Speech Setting" in the Setting menu.  You can also 
change the volume, the pitch and the rate of aloud reading. 
 
4.3.2  Other Settings and Commands Concerning math Reading 
If "Read Menu" in the Setting menu were not checked, menu items such as the symbol list 
would not be read out. 
 
You can suppress speech output of "space" and "return" by pressing Ctrl + F8 key or using 
"Read Aloud Line Break Marks" in the Setting menu. 
 
If "Read Entire Line" in the menu were checked, entire contents up to a carriage return line feed 
would be read out when the cursor would come to that line. 
 
If "Automatically Reading Mode" were checked, the cursor would move ahead automatically, 
and contents would be read out without cursor operations. 
 
Remark: 
With "Read Out" menu commands, you could also listen to a content without cursor operations.  
However, in this case, the cursor would keep its original position. 
 
Using a shortcut: the Ctrl + Alt + H, you can check the font style such as bold, italic.  
Incidentally in math expressions all alphanumeric letters are math italic. 
 
In the Setting menu, there are also other useful commands such as ones concerning highlighting, 
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etc. 
 
4.3.3  Aloud-Reading Table Editor 
Using this editor, you can change a way in which each symbol is read aloud.  The "Default" 
button cancels all of the customization made by the user.  You may save a customized table in 
another name and apply it with "Select Reading Table" in the Setting menu. 
 
4.3.4  Edit Math Reading 
You can edit how to read math syntaxes are read aloud from beginning to end (not character-
by-character). The default definition file named "ReadSetting_SAPI5_En.txt" is located in: 
 C:¥Program Files¥sAccessNet¥ChattyInfty3¥language¥ReadSetting¥. 
You may edit it by using any text editor.  You can customize all of the three types of aloud 
reading for math syntaxes.  In addition, the manner of aloud reading of each math symbol also 
can be edited on this text file.  The result is automatically reflected in the definition table of 
them. 
 
4.3.5  Reload Math Reading 
While ChattyInfty is running, the new definitions can be reload with this command. 
 
4.3.6  Assigning Another Manner of Aloud Reading 
There are many math formulas that have ambiguity in reading out them.  For instance, a mixed 
fraction could be read as the product of an integer and a fraction.  X squared could be read as 
the second component of a vector.  We often have to assign them an appropriate manner of 
aloud reading, according to their context.  Unfortunately, however, since it is impossible to 
assign the appropriate aloud-reading to them automatically, we do need a new way to handle 
how to read out each symbol or math formula locally according to their context.  We refer to 
this new concept of assigning a pronunciation as "Yomi" (a Japanese word that means "a 
manner of aloud reading").  We actually give a concrete method to assign Yomi to math 
expressions in ChattyInfty3. 
 
After selecting a certain part of a math formula, press the Shift + Ctrl + Down key; then, a 
dialog to assign Yomi will appear.  You can give any word description for the part with it.  
You also can open the Yomi dialog with "Open Yomi Setting" in the Format menu. 
 
Remark: 
Instead of Yomi, pressing the Shift + Ctrl + Up key opens a "Ruby Setting" dialog.  Ruby is 
similar to Yomi; however, a word description assigned as Ruby is displayed explicitly by the 
side of an original formula while Yomi is not.  Ruby is very useful in a Japanese text; however, 
we do not think it would also need in English. 
 
 



18 
 

5.  View Menu 

5.1  Last Reading Bar 

"Last Reading Bar" is a one-line window to show a character string of sentence that ChattyInfty 
has just spoken.  You can open this window with the View menu and move to it with the F6 
or Ctrl + F6 key. 

5.2  LaTeX Source Bar 

"LaTeX Source Bar" is a one-line window to display a character string of LaTeX source that 
corresponds to the line the cursor is currently located.  You can open this window with the 
View menu and move to it with the F6 or Ctrl + F6 key. 
 
 
6.  Setting Menu 
 
There are many useful commands available with the Setting menu other than ones described up 
to now. 

6.1  Standard Font Selection 

The user can select the font and the size to be used by ChattyInfty.  It will be applied to the 
entire document. 

6.2  Option Setting 

Using the "Text/Math Change Shortcut," you can choose one of the following 2 ways to switch 
the Text/Math modes: 

a. Ctrl Key   You can switch the Text/Math modes by pressing the Ctrl key only, 
b. Ctrl + Space key   You can switch the Text/Math modes by pressing a Space key together 

with the Ctrl key. 
 
Using the "Backslash Command in Text mode," you can choose the role of backslash key in the 
text mode.  It could be either the symbol of backslash itself or the prefix of LaTeX commands. 
 
Using "Cursor Order in fraction," you can if cursor will move first to the numerator or the 
denominator. 
 
When the "Space Mark" for "Text mode space," "Math mode space" or TeX mode space are 
checked, spaces will be marked in color so the reader will know their location. 
 
If "Ctrl + Up/Down to Super" were checked, the Ctrl + the Up Arrow key would be a shortcut 
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to move the cursor to the superscript position.  Pressing the Up Arrow key alone would simply 
move the cursor to the previous line. 

6.3  Convert Options 

6.3.1  Import Group 
In this group, you can choose the formats to be imported to ChattyInfty.  Only the checked 
items will appear in the Import command in the File Menu. 
 
The choices are 

a. LaTeX Source Import - a LaTeX formatted file can be converted IML format and be loaded 
to ChattyInfty. A LaTeX command that ChattyInfty cannot convert is imported as in TeX 
mode.  

b. OCR-file(KML) Import - a recognition result file of ChattyInfty, KML file, can be loaded 
to ChattyInfty. 

 
6.3.2  OCR Import Group 
In this group, you can choose sources which can be recognized by ChattyInfty and set some 
parameters for the recognition.  

a. Import from Scanner   You can recognize documents by ChattyInfty via a scanner. 
b. Import from Image File   You can recognize documents as page image files. 

These items appear in the Import command of File menu if you checked them. 
c. Delete KML after OCR   ChattyInfty saves recognition results in a KML file. 

If you check this option, ChattyInfty deletes the KML file after recognition. 
d. Include Image Areas   ChattyInfty saves images included by a recognized document in a 

KML file. 
 
6.3.3  Export Group 
In this group, you can choose some kinds of formats to be converted from edited documents by 
ChattyInfty.  Only checked items appear in the Export] command of File menu. 

a. LaTeX Output   An edited document can be saved in LaTeX format. 
b. HTML Output   An edited document can be saved in HTML and each mathematical 

expression will be saved as an image file. 
c. MathML Output   An edited document can be saved in MathML. 
d. Human Readable TeX Output   An edited document can be saved in Human Readable 

TeX (HR-TeX).  In the HR-TeX, mathematical expressions are described in LaTeX 
format, but some LaTeX commands that are not needed to describe context of a document 
(e.g. environmental commands, layout comments, etc.) are omitted. 

e. Karlsruhe AMS-notation Output - Karlsruhe AMS (ASCII Mathematik Schrift) is 
developed in Karlsruhe University to describe mathematical expressions only using ASCII 
characters. 
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6.4  Math Level 

The math levels are: 
  Junior high school math, 
  Senior high school math, 
  University math, 
  Professional math. 
Since ChattyInfty provides many symbols for highly technical materials, setting the correct 
level limits the choices of symbols. 

6.5  Language 

In ChattyInfty3, a user could change a language to read out contents if necessary definition files 
were installed.  To change a language actually in ChattyInfty3, one should change three (3) 
items in the Setting menu. 
 - Choose the (local) language at "language" in the Setting menu.  At that time, after pressing 
the OK button, rebooting the software should be required. 
 - Select a local TTS voice at “Speech Setting“ in the menu.  If you could not find it in the list, 
please see "SpeechFiveMagic.docx" included in: 
 C:¥Program Files (x86)¥sAccessNet¥ChattyInfty3¥lang¥documents. 
 - Finally, to change ReadSetting_SAPI5.txt to the local-language version, open "Select 
Reading Table" in the menu and choose an appropriate one. 
 
Remark: 
In addition to the above points, please check the font setting at the Option tag in the Setting 
menu.  If a font other than Times New Roman were chosen, change it to Times New Roman.   
 
Remark: 
ChattyInfty3 provides end users with "Localization Kit" that allows them to customize 
ChattyInfty3 so that it can treat their local language other than already-installed ones. 
Concerning this point, please read "InstructionsForMultilingualSupportInChattyInfty3.docx" 
included in: 
 C:¥Program Files (x86)¥sAccessNet¥ChattyInfty3¥lang¥documents. 
 
 
7.  Using ChattyInfty with Other Screen Readers 

7.1  Using ChattyInfty with JAWS 

Since the current version of ChattyInfty could read out all the contents and menus, you might 
not need to utilize another screen reader with ChattyInfty if you hoped math access with speech 
output only.  However, if you would like to make use of a Braille display, you would have to 
use a screen reader such as JAWS along with ChattyInfty since it has no function to output 
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Braille directly.  When ChattyInfty is used with JAWS, some conflicts between their speech 
outputs will take place. 
 
In order to avoid the speech conflictions, we prepared JAWS's script files for ChattyInfty.  If 
necessary, please install them in the following manner. 
 
Put three script files included in the package of ChattyInfty into the setting folder of JAWS for 
each local language.  For instance, the setting folder in English OS might be: 

C:¥users¥"YourAccount"¥AppData¥Roaming¥Freedom-
Scientific¥JAWS¥14.0¥settings¥ENG¥. 

 
Remark: 
Since Windows7, JAWS scripts installed in a certain user’s account does not work for the other 
users. 

7.2  Output to Braille Display 

The script files for ChattyInfty not only suppress JAWS's speech but also send the content of 
TeX-source-bar window to the Braille display via JAWS.  In order to use this function, you 
need to open this window with the View menu. 
 
Remark: 
The LaTeX Source Bar only shows a character string of the LaTeX source that corresponds to 
the line the cursor is currently located.  The position of cursor is not indicated.  Furthermore, 
you may need to tune the setting of your Braille display to show the content correctly. 
 
 
8.  Operations concerning LaTeX 

8.1  About TeX Environment 

The document created by ChattyInfty can be exported into LaTeX format. You can compile it 
and preview the DVI file on ChattyInfty.  Furthermore, the DVI file can be converted into PS 
(PostScript) file or PDF (Adobe Portable Document Format) file.  However, to use these 
functions (except for exporting LaTeX), you must install TeX environment in your PC.  You 
can download an archive file of LaTeX installer package including all the necessary tools to use 
LaTeX functions in ChattyInfty from the site: http://www.inftyproject.org/en/download.html 

8.2  Description of Operations concerning LaTeX 

8.2.1  Exporting LaTeX 
You can export the document created by ChattyInfty into LaTeX format by selecting the item 
"LaTeX Output" from the TeX menu. 
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8.2.2  Editing Source 
You can edit the LaTeX source file just created, by selecting the item "Edit Source" from the 
TeX menu. 
 
8.2.3  Compiling LaTeX Source 
You can compile the LaTeX source file by selecting the item "Compile" from the TeX menu. 
 
8.2.4  Previewing DVI File 
You can preview the DVI file by selecting the item "Show DVI File" from the TeX menu. 
 
8.2.5  Opening Log File 
You can open the LOG file output after LaTeX compiling by selecting the item "Show LOG 
File" from the TeX menu. 
 
8.2.6  Converting to PS 
You can convert the DVI file to PostScript(PS) file by selecting the item "DVI -> PS Convert" 
from the TeX menu. 
 
8.2.7  Converting to PDF 
You can convert the DVI file to PDF file by selecting the item "DVI -> PDF Convert" from the 
TeX menu. 

8.3  Setting concerning LaTeX Output 

8.3.1  Preamble Setting  
By selecting the item "Preamble" from the TeX menu, the dialog box "Setting TeX" appears.  
You can design the preamble to be output in the heading of LaTeX source file.  The preamble 
design can also be read from existing LaTeX source in user's PC, by clicking the "Input from" 
button in the dialog box. 
 
8.3.2  Treatment of Spaces and Line Feeds 
You must select one of the two modes in the conversion of ChattyInfty source to LaTeX source.  
One is "quasi-WYSIWYG mode" that converts each line feed in the ChattyInfty source file to 
a double line feed in the LaTeX source file, and outputs so that the screen and the printing are 
almost the same.  You can select this mode by clicking the check box in the dialog box opened 
by selecting the item "LaTeX Output Option" from the TeX menu.  The other one is "LaTeX 
source editing mode" that outputs spaces and line feeds in the ChattyInfty source file to LaTeX 
source file without changing.  Please see the next subsection about the control of spacing and 
line feeds in "LaTeX source editing mode". 

8.4  Input Guide for LaTeX Source Editing Mode 
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In writing a source file using LaTeX, the treatment of spaces and line feeds are different from 
writing text with usual word processors.  The following hints will help avoid problems: 
 
8.4.1  Treatment of Spaces 
In LaTeX, the spaces are automatically treated, and the spaces in the source file are ignored 
when printing.  If you want to place blank intentionally, you must specify it explicitly in the 
source file as follows: 

a. Space in horizontal direction: ¥+space, ¥quad, ¥hspace{1.5cm}, etc. 
b. Space in vertical direction: ¥bigskip, ¥medskip, ¥vspace{3cm} , etc. 

 
8.4.2  Line Feeds 
Line feeds at the end of each line in LaTeX source files are ignored when printing.  If you need 
to start a new line, insert a blank line at the position where you want to do so.  Another way is 
to use line feed command, "¥par".  Since these two line feeds mean the end of a paragraph, 
the line following them is automatically indented.  If you want to change a line without the 
indent, use "¥¥" command instead of "¥par or the blank line.  You may also use "¥noindent" 
command. 
 
Note that users should adopt the above two rules with "LaTeX source editing mode".  
ChattyInfty displays the formula, bold/Italic, centering, etc. on the screen in the print style as 
much as possible. However, to ensure that you can write freely without sacrificing LaTeX's 
power for expressions, the controls of spacing and line feeds in "LaTeX source editing mode" 
are defined according to the above two rules. 
 
8.4.3  Half size Spacing 
You can insert a half size space by Shift + space.  The half size space in "LaTeX source editing 
mode" is converted to "¥" in LaTeX source file. 
 
8.4.4  Formulas and Text 
Each mathematical formula written within other texts is output between the single $ commands: 
$ ... $ in LaTeX source file.  On the other hand, if you center the line which consists only of 
mathematical formula, it is output between the double $ commands: $$ ... $$ as the display 
style formula in LaTeX.  The centered line of formula is treated as independent one when you 
start the new line with Enter key; however, if you use Shift + Enter instead, successive lines are 
treated as one display style formula. 

8.5  Enhanced Command Input 

ChattyInfty provides "TeX Mode" in both of "quasi-WYSIWYG mode" and "LaTeX source 
editing mode" so that you can use other symbols not available in ChattyInfty.  Many other 
convenient commands of LaTeX such as ¥section, ¥subsection, ¥label, ¥begin{figure}, 
¥begin{enumerate}, etc. are also provided.  By selecting "TeX Mode" from the Format menu, 
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you get into "TeX Mode".  Then, keyboard input strings are not converted automatically even 
if they include ¥ sign; they are displayed as strings of TeX commands.  The characters input 
in "TeX Mode" in Text area is displayed in red (default).  The characters input in "TeX mode" 
in Math area is displayed in brown (default). 
 
 
9.  File Operations 

9.1  Available File Formats for Import 

File formats that ChattyInfty3 can open are: 
 
* XML file especially created with Infty software (*.imlx) 
You can open IMLX files by selecting the item "Open" from the File menu.  You can save the 
documents created in ChattyInfty3 as a special Infty XML file (*.imlx) by selecting the item 
"Save" from the File menu (or Ctrl + S).  You can also save the documents created in 
ChattyInfty3 as IMLX file with new filename by selecting the item "Save As" from File menu. 
 
Remark: 
In the old version, ChattyInfty2, the Infty original format was IML.  An IML file can be 
imported into ChattyInfty3, and an IMLX file can be output as an IML file. 
 
* LaTeX Source file (*.tex) 
You can open a LaTeX file by selecting the item "Import LaTeX" from "Import" in the File 
menu. 

9.2  Available File Formats for Export 

Output formats other than IML such as LaTeX, HTML, MathML, "Human Readable TeX", 
spoken text and Microsoft Word xml were available in the previous version, ChattyInfty2.  In 
ChattyInfty3, besides them, accessible e-book formats: DAISY (2 or 3), Accessible EPUB3 and 
ChattyBook are also available as export format. 
 
 
* Exporting to LaTeX 
You can export the document created in ChattyInfty into LaTeX format by selecting the item 
"LaTeX" from "Export" in the File menu (or Shift + Ctrl + T). 
 
* Exporting to HTML 
You can export the document created in ChattyInfty into HTML format by selecting the item 
"HTML" from "Export" in the File menu (or Shift + Ctrl + H). Mathematical expressions will 
be inserted as PNG format images. 
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* Exporting to MathML 
You can export the document created in ChattyInfty into MathML format (*.xml) by selecting 
the item "MathML" from "Export" in the File menu (or Shift + Ctrl + L). Mathematical 
expressions will be inserted not as images but as MathML. 
 
* Exporting to Human Readable TeX 
You can export the document created in ChattyInfty into "Human Readable TeX" format (*.txt), 
which is an alternative simpler syntax for people with print disabilities who are familiar with 
LaTeX.  Export by selecting the item "Human Readable TeX" from "Export" in the File menu 
(or Shift + Ctrl + X).  
 
* Exporting to Spoken Text 
You can export the document created in ChattyInfty into a text file consisting of a spoken text 
by performing "Spoken Text" command from "Export" in the File menu.  Since, inn this file, 
all math expressions are replaced with their word descriptions, you can read it with another 
screen reader. 
 
* Exporting to Microsoft Word 2007 (or later) XML 
You can export a document created in ChattyInfty as a Microsoft Word 2007 (or later) XML 
document.  In that Word file, all the math expressions are represented in Word math objects.  
You can edit them with the math editor in the Word; however, you cannot with ChattyInfty3, 
again. 
 
Remark: 
If another software: "MathType" were also installed, you could convert a Microsoft math object 
into a MathType object.  Then, you could edit them with MathType. 

9.3  DAISY, Accessible EPUB3 and ChattyBook Export 

As is well known, The Digital Accessible Information System (DAISY) is now becoming a 
standard format of accessible e-books.  Furthermore, the International Digital Publishing 
Forum (IDPF) decided to adopt DAISY XML as a part of EPUB3 standards in 2011.  DAISY 
and accessible EPUB3 are excellent solutions for making printed content more accessible to 
people with various print disabilities.  In the previous version, DAISY2, a mathematical 
expression was treated as an image with an alternative text.  Since MathML is officially 
adopted in the current version, DAISY3 and EPUB3 (DAISY4), we would become able to 
produce a text-based/multimedia mathematical content, in which one could access a math 
formula character by character, symbol by symbol with speech synthesis.  A blind user can 
read mathematical documents with speech output.  A low-vision reader can improve contrast 
or magnify the displayed content for ease of reading.  Visual tracking and synchronized speech 
allow a dyslexic reader to maintain focus on a document. 
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Since, in ChattyInfty3, DAISY, Ver.2 and 3 and accessible EPUB3 are officially adopted as 
export formats, math/scientific contents produced with ChattyInfty3 can be converted into 
accessible e-books in DAISY/EPUB3.  The index structure or other settings such as Yomi in 
ChattyInfty will be preserved in DAISY/EPUB3 contents.  Now, you can use ChattyInfty3 as 
excellent authoring tools to produce accessible e-books.  "Export DAISY" and "Export 
EPUB3" commands in the File menu allow you to do that. 
 
Remark: 
In addition to that, with the "Export ChattyBook" command, you can convert a ChattyInfty3 
document into a DAISY-like HTML5 file.  You can browse it with any browser.  You do not 
need a DAISY/EPUB3 player. 

9.4  Page Setting and Printing 

You can set the page property by selecting the item "Page Setup" from the File menu.  The 
standard page properties in ChattyInfty are as follows:  
 

a. Paper size: A4, A5 and Japanese-own standard sizes, B4 (10 by 14 inches) and B5 (7 by 
10 inches) 

b. orientation: Vertical, Horizontal 
c. Margin 
d. Page layout: Single or Two columns, Output page numbers 
e. Page title 

If the document contains 2 or more pages, page numbers will be shown in the footer 
automatically.  You can also select no-page-number output mode.  

9.5  Control of Page Break 

As will be seen later, inserting a page break and combining two pages are supposed to be done 
with the Index menu. 
 
 
 
10.  Index Menu 
 
Editing the index can be done in an intuitive manner.  The head line of each page is 
automatically treated as a top item in the index.  It appears on the first level of a tree diagram 
in the index window.  Using "Index" menu, a user can perform various commands concerning 
the DAISY index.  "Page Break" and "Join" commands are used to divide a page into two 
pages and to combine multiple pages, respectively.  When performing the Page-Break 
command, the top line of a new page is automatically treated as the first-level item in the index. 
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"Add Index" and "Remove Index" commands are used to create a new index item and to delete 
some items, respectively.  Performing the Add-Index command after selecting a certain part 
in the document such as the title of a subsection, users can add it onto the second level of the 
index.  It appears at the right-hand side of the top level in the index window. 
 
Index items can be moved from a certain level to a higher level or vice versa with "Level Up" 
or "Level Down" commands in the Index menu.  On the other hand, "Order Ahead" and "Order 
Behind" commands in the Index menu are used to move items within the same index level. 
 
 
11.  Other Menus 

11.1  Edit Menu 

From the Edit menu, operations listed below are available: 
* Undo:  (U)  [or Ctrl + Z] 

It undoes up to 10 steps back to the previous status. 
* Redo:  [or Ctrl + Y] 

It redoes the undone steps. 
* Cut:  (T)  [or Ctrl + X] 

It cuts the selected range and holds that item on the clipboard. 
* Copy:  (C)  [or Ctrl + C] 

It copies the selected range and holds that item on the clipboard. 
* Paste:  (P)  [or Ctrl + V] 

It pastes the item cut or copied. You can also paste a character string copied in the 
ChattyInfty file (*.iml) to other applications through Windows clipboard. If it includes 
mathematical expressions, they will be pasted in the LaTeX format. You can paste a 
character string written by other text editor with math expressions in the LaTeX format to 
ChattyInfty files. 

* Delete:  (D)  [ or Del] 
It deletes the selected range. 

 
NOTE: The above six commands can be also performed from the Context menu that pops up 
by pressing the Application key on the keyboard or the right click. 
 
* Select All:  [or Ctrl + A] 

It selects all the content in the currently opened document. 
* Insert Image (figures, charts and images): 

It inserts a figure, a chart or other images as image into the iml file.  In order to insert 
images, you have to prepare image files in one of the following formats:  

.bmp, .jpeg (.jpg), .png and .tif (without lzh compression). 
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If you select "Image Position" from the Context menu, you can select the image layout and 
its size.  Note that it is not possible to insert images into super/subscript positions. 

* Copy of math expressions as Images:  [or Ctrl + Shift + C] 
Using this command, you can paste math expressions made in ChattyInfty to other software 
in alternative form other than LaTeX.  Since math expressions written in ChattyInfty can 
be copied as images into the clipboard of Windows, they can be pasted into various 
Windows applications such as Microsoft Word, PowerPoint and so on. 

 
11.2  Format Menu 
From the Format menu, operations listed below, etc. are available. 
* Text mode  (T) 
* Math mode  (M) 
* TeX mode  (X) 
* Footnote mark: 

When entering a footer text in a scientific document, select whether it should be superscript 
or subscript within an original line height (level). 

* Font Style: 
Italic and Bold commands emphasize the selected range with each style.  Characters that 
can have Italic or Bold styles are limited to Numeric, Roman, German, Latin and Latin2.  
Pressing Ctrl + I key changes the style to Italic, and Ctrl + B key changes it to Bold.  You 
can check out the style of already-entered character by pressing Ctrl + Alt + H. 

* Frame line: 
When you want to insert a blank box, enter spaces first, select them and choose "frame line" 
command; then, the box is entered at that position.  Note that these blank boxes are 
currently incompatible with LaTeX output. 

* Font size: 
A standard size is established by the Setting menu.  The standard size set here indicates the 
"Medium" in "font size" in the Format menu (actual size: F3 in the list).  From this standard 
size, "large" and "ultra large" commands enlarge the size by 2 and 4 points, respectively. 
"small" and "ultra small" commands reduce it by 2 and 4 points, respectively.  These 5 
levels in total become the optional font sizes.  The font size can be changed with the Format 
menu. 
 
When you want to change the font size for the line already entered, move the cursor to the 
line and select new size from the menu.  The same size will be applied to all lines in the 
paragraph concerned. 
 
Since only one standard size is effective in one file, if you change the setting of standard 
size in the middle of it, the standard size (Medium:  F3) will be changed for the entire file. 
 

* Centering: 
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Character layout can be changed for paragraphs as a unit by the following commands: Left 
align, Centering, Right align 

11.3  Find Menu 

You can Find and Replace character strings not only in the Text mode but also in the Math mode.  
Commands listed below are available. 
 
* Find in Text   [or F3], 
* Replace in Text, 
* Find in Formula   [or Ctrl + F3], 
* Replace in Formula. 
 
 
12.  Contact Information 
 
Contact information can be found on our web site, 
URL  http://www.sciaccess.net/en/index.html. 
 


