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1.  Introduction

Welcome to ChattyInfty!  ChattyInfty is a mathematical document editor to provide speech-output access while reading, writing or editing scientific documents.   

This software was developed by the Science Accessibility Net Project.  Our organization also offers many services to help visually disabled people with accessing scientific information.  Please visit the web site of Non-Profit Organization, Science Accessibility Net (or sAccess Net, shortly), http://www.sciaccess.net/en/index.html.

1.1  Features

* Math expressions or scientific documents ranging from secondary education to higher education levels can be written or edited by using the keyboard with speech output. 

* Files made by ChattyInfty can be saved in various accessible formats: LaTeX, MathML, PDF, or HTML.  IML (Infty Markup Language) format is essentially XML and is completely compatible with other Infty software: the math OCR　software, "InftyReader" and the Math-document editor for sighted people, "InftyEditor."
Information displayed on the main window of ChattyInfty is completely equivalent to that of InftyEditor.  All of math expressions are displayed in the ordinary print style.  ChattyInfty reads aloud not only texts but also those math expressions.  Visually disabled students can access, write or edit scientific documents including math expressions, with speech output.  They, therefore, can share the same educational materials with their classmates. Their teachers can easily prepare those materials by making effective use of InftyReader and InftyEditor.  Furthermore, the teachers can directly read documents that visually disabled students draw up even if they are not familiar with Braille.

1.2 System Requirements

The operating system should be either Windows 2000, XP or later. The Microsoft Internet Explorer 6 or later must be installed. Microsoft speech API version 4 must be installed.

2.  Installation and Activation

Perform setting.exe in the ChattyInfty folder and follow the instructions.  After installation, you will be asked to complete the on-line activation.  You can find information about them on our web site:


http://www.sciaccess.net/en/.

3.  Getting Started

3.1  How to Input

ChattyInfty is started by "Text (input) mode."  In this mode, you can write or edit literary texts with the keyboard.  To input math expressions, press Ctrl + Space key to switch to the "Math (input) mode."  By using this key stroke, you can switch between "Text" and "Math" input mode.  

Remark:

You can change the shortcut to switch them, using setting menu.

You can set up different voices for each of text and math parts with Speech menu.

3.2 Using Math Input Mode

To input characters or symbols which are not on the keyboard, ChattyInfty provides two methods as follows:

3.2.1  Keyboard-based input method

Enter "\" followed by specific name (the TeX command), then convert it with Space key or Enter key.  For instance, if you want to input Greek letter alpha, enter \alpha from keyboard and then press Space (or Enter) key.  When you start inputting the command, the choices that have the same initial letters are displayed; so, you can choose an appropriate one from them.

3.2.2  Menu-operation-based input method

Select from the Context menu that pops up by the Application key (or right click).  How to do it will be explained later.

Up to five Characters recently selected are displayed in the Context menu.  It may be convenient when you use same characters repeatedly.  See "Input reference" (List of characters and symbols) in the Help menu for the character/symbol commands and their classification. 

Apart from Math-mode symbols, Latin character sets in Text mode are also available from the symbol lists that pops up by pressing the Application key (or right click).

3.3 Creating Math Formulas

3.3.1 Superscript and Subscript

To write an x squared, do the following:

1.  Type the base letter, "x".

2.  Press the Up Arrow key or Input ^ (hat).  The cursor will move to the superscript position, and ChattyInfty will say "power."  

3.  Type the 2 and press the Enter key. The cursor will return to the base line.

To write a x sub n, do the following:  

1.  Type the base letter, "x".

2.  Press the Down Arrow key or _ (Under-bar).  The cursor will move to the subscript position, and ChattyInfty will say "sub."

3.  Type the "n" and press the Enter key.  The cursor will return to the base line.

Remark:

Using the setting menu, you can change the setting so that, instead of the Up/Down arrow keys, the Ctrl + Up/Down arrow keys moves the cursor to the super/subscript position.  At that time, the Up/Down arrow key simply moves the cursor to the previous/next line.

3.3.2  Special Characters

As was mentioned previously, mathematical characters that are not on the keyboard can be input from the Context menu that pops up by pressing the Application key on the keyboard, pressing Shift F10 or right clicking the mouse.  In the Character/Symbol set, there is a list of many special characters.  

To write a Greek letter, alpha, do the following:

1.  Press the Application key to open the Context menu. ChattyInfty says "Context menu."

2.  Press the Down Arrow key several times to find an item, "Character, Symbol."

3.  Press the Right Arrow key to move to the submenu; then, ChattyInfty says "Greek."

4.  Press the Right Arrow key to move to the entry list of the Greek letters.

5.  Select alpha and press Enter key.

You can input a variety of special characters from the Context menu.

To write a symbol of "is greater than or equal to", do the following:

1.  Press the Application key to open the Context menu. ChattyInfty says "Context menu."

2.  Press the Down Arrow key several times to find the item, "Character, Symbol."

3.  Press the Right Arrow key to move to the submenu.

4.  Press the Down Arrow key to find an item, "Relative Symbol."

5.  Press the Right Arrow key to move to the entry list of the relative Symbols.

6.  Select the symbol of "is greater than or equal to" and press Enter key.

3.3.3  Math Syntax

Besides the superscript and the subscript, there are many special notations in mathematics. We call them "Mathematical syntaxes." They can be also input from the Context menu.  To input characters/symbols in a place other than a base line such as fractions made of a denominator and a numerator, radicals in which characters and symbols are written in certain layout or other math syntax with super/subscript around symbols (a summation, for instance), the following methods are provided.

A. Keyboard-based Input Method

First, enter \ followed by a certain name (TeX command) and then, press the space (or Enter) key.  The cursor moves to inside of the syntax so that you can enter characters and formula.  If you need to enter super/subscript area in the syntax (the index in radicals, for instance), press the right/Left Arrow keys after entering the base characters; then, the cursor moves to the positions that need to be input.

B. Menu-Operation-based Input Method

Select the syntax from the Context menu that pops up by the Application key (or the right click).  Pressing Arrow keys to let the cursor move to inside of the syntax; then, you can enter characters and symbols in it.

You can refer to "Input quick reference"(Mathematical Syntax List) in the Help menu to check each command and input method.

To write the fraction, "one over two" do the following:

1.  Press the Application key to open the Context menu. ChattyInfty says "Context menu."

2.  Press the Down Arrow key several times to find an item, "Formulas."

3.  Press the Right Arrow key to move to the submenu.  ChattyInfty says "Frac."

4.  Press the Enter key.  A blank fraction is placed at the original position of cursor.  The cursor moves to its numerator position automatically. ChattyInfty says "Numerator."  You can also enter \frac (or simply\f)

5.  Type "1" and press the Right Arrow key to move the cursor to the denominator position. ChattyInfty says "Denominator."

6.  Type "2" and press the Right Arrow key and the cursor will move out of the fraction to the next position on the base line.

Remark:

Pressing the Enter key also moves the cursor to the denominator position or outside of the fraction; however, no messages will be spoken.

To write the square root of 2, do the following:

1.  Press the Application key to open the Context menu. ChattyInfty says "Context menu."

2.  Press the Down Arrow key several times to find the item, "Formulas."

3.  Press the Right Arrow key to move to the submenu.

4.  Press the Down Arrow key once; then, ChattyInfty says "Square Root." Or you may enter \sqrt (or simply\r)

5.  Press the Enter key.  A blank radical is inserted at the original position of cursor.  The cursor is located inside the radical.  ChattyInfty will say "Inside Radical."

6.  Type "2" and press the Right Arrow key to get out of the radical.

Remark:

If you want to input a general radical, you may use another command: "Radical."  Be sure that radicals in ChattyInfty have three areas: the radical index area, a main area and a superscript area, or the power for the entire radical.  Using the Context menu, you can write many of other special mathematical notations.  

3.3.4 Other keyboard shortcuts

* Summation-Type syntax:

(Symbol with sub and superscript areas) 

Input \sum (or simply \s).

* Limit-Type syntax:

(Symbol/Character string with one subscript area)

Input \lim .

* Integral-type Syntax:

Input \int (or simply \i).

* Accent Mark:


Input \overline.

Note: Latin letters in text area (e.g. accent and cedilla of French) are not assumed as the accent marks in mathematical syntax in the Math mode. They can be displayed in font as Latin letters in text mode. Also, accent marks for math expressions do not work in the text mode. 

(See the Symbol list of Latin 1 and Latin 2 in the Context menu.) 

* Matrix-type syntax:

A manner to input big (multi-line) enclosing symbols for matrices, simultaneous equations and so on is as follows: 

Input \ followed by one of [, {, (, |, || from the keyboard. 

If the closing symbol is not necessary (in the case of Simultaneous equations, for instance), press the Right Arrow key after completing to enter the content, to let the cursor move to the position just in front of the closing symbol. (At that time, the cursor is located at the same height as the closing symbol.)  Then, delete the closing symbol with the Delete key. 

The width and length of enclosed area is automatically adjusted depending on the size of content; however, the elements are not aligned automatically. You need to align them for yourself by using spaces or tabs.

3.4  How to Input from Math OCR

Using ChattyInfty, people with visual disabilities can access printed scientific documents including math expressions.  In order to use this function, you need to install our math OCR system named "InftyReader, Ver. 2.6X"  Since they recognize not only special characters but also mathematical notations and import the results into ChattyInfty, you can access or edit them with speech output.  InftyReader, Ver. 2.6X can recognize printed documents including those with tables and also PDF files.  

3.4.1 What Is InftyReader?

InftyReader is an OCR software for scientific documents, which was also developed by our research group, Infty Project. InftyReader recognizes scanned page images of English documents including mathematical expressions. From each page image, figure areas, table areas and text areas are segmented automatically.

Download site of InftyReader is: 


http://www.sciaccess.net/en/.

3.4.2  System Requirements

InftyReader runs on MS Windows XP.

3.4.3  Language

The current version (English edition) can recognize only printed documents in English. Be aware that it does not recognize Japanese characters at all. Mixture of other occidental languages (e.g. French, German etc.) will be accepted to some extent.

3.4.4  Quality of Source Image and their File Format

The Infty system recognizes only binary (black and white) page images carefully scanned in either 600 DPI or 400 DPI. The image files have to be prepared in TIFF, GIF or PNG format.  Although older versions of InftyReader could not read GIF files and TIFF files with LZW compression, the newer versions of InftyReader (Ver.2.4.3c or later) can read all these file formats. 

The source documents have to be clearly printed. Please adjust the binarization threshold of your scanner so that, in scanned page images, the number of the touched or broken characters should be less than 1% of the total number of the characters in each page. 

InftyReader erases small noises, segments page images into figure areas, table areas and text areas, and then recognizes text areas including mathematical expressions. However, to get better recognition results, users are recommended to erase noises, figures and tables before the recognition starts.

3.4.5 How to Recognize

Follow these simple steps:

  a. Prepare a scanned image file in either TIFF, GIF or PNG format.

  b. Start InftyReader and select the file.  If the folder were selected, InftyReader would recognize all the files contained in that folder.

c. Press the Start button.  After the recognition completing, the recognition result would be automatically displayed on the ChattyInfty window if the check mark were checked.

See the manual of InftyReader for more detailed information.  You can also perform OCR from the menu of ChattyInfty.  At that case, you may use "Import" in the File menu.

3.4.6  How to Use the Sheet View Window

When the recognized result is displayed on the main frame of ChattyInfty, the "Sheet View window" pops up to show the original page image. Since the original scanned image that exactly corresponds to an area around the cursor position is displayed, sighted people can easily check any errors of the recognition.

It is remarkable that information on the Sheet View window is also available for visually disabled people. By pressing F4 key, the focus moves to the Sheet View window. If you had a certain sophisticated tactile-graphic tool such as View Plus embossers, you could output the image directly from this window as tactile graphics. So, even if you were totally blind, you could grasp and correct recognition errors for yourself with the tactile graphics.  Printing the Sheet View window is supposed to be done from the own File menu of this special window. The focus will be back to the main window when you move the cursor with Arrow keys.  

4.  Speech Output

4.1  Speech Engine

Since ChattyInfty uses Microsoft speech API (SAPI), the version 4 as the speech engine, it must be installed. If the SAPI is already installed, ChattyInfty will speak automatically when it is started.

4.2  Reading Aloud

ChattyInfty reads aloud texts and also math expressions. You can access, write or edit scientific documents including math expressions with speech output.

4.2.1  Reading of Text 

In the text part of the document, operations concerning aloud reading are almost same as other screen readers. When the cursor is moved to the next or previous line with the Down or Up Arrow key, ChattyInfty reads aloud the content of line from the beginning to the end. When the cursor is moved to right or left, ChattyInfty reads aloud the one character that is just located at the right hand side of the cursor. You can read the text in a word-by-word manner by pressing Ctrl + the Right/Left Arrow key.
Remark:
By using "Speech menu", ChattyInfty reads out automatically an indicated part of document without cursor operations.

By pressing Ctrl + F1 key, you can hear the line and page numbers where the cursor is currently located.

If the "Page Frame" in the "File" menu were on, you could jump to the indicated page by pressing the Ctrl + Shift + G.

Using the "Speech" menu, you can change the kind of SAPI voices, its pitch and speaking rate.  The voices and pitches for the text and math parts can be different from each other.
4.2.2.  Reading of Math Expressions

You can also browse a math expression with the cursor operations; however, you should be careful because the behavior of cursor when pressing Arrow keys is different from that in text.  For instance, if you pressed the Up Arrow key, the cursor would move to its superscript position, not to the previous line.  To move to the previous line, you need to press Ctrl + the Up Arrow key.  Also to move the cursor to the next line in the math expression, you need to press Ctrl + the Down Arrow key.  If you find this confusing, this function can be changed so that the Ctrl + Up/Down arrow key moves the cursor to the super/subscript position.  In this case, the cursor goes simply to the previous/next line by pressing the Up/Down key only.  

Remark:

By using Speech menu, ChattyInfty reads out automatically math expressions without cursor operations.

4.2.3  Details about Reading Math Expressions Aloud

ChattyInfty has a defined way to read aloud each math symbol. They are classified into several groups and listed in the Context menu. If necessary, this defined way of reading aloud, can be changed in the Speech menu described later in this manual.

Each special notation in mathematics ("math syntax") is read aloud in the defined way. Here are some examples:

Superscript:

x squared is read aloud in these ways:.

a. When reading it straight through, it is "x squared"

b. When reading it character by character from beginning to end, it is "x power 2, end power"

c. When reading it character by character from end to beginning, "power 2, left super, x"

Here, "left super" indicates a superscript area on the left hand side of x. This area is skipped in the case b.  If there were letters in this area, they would be read with a rising intonation before the base character in the case a.

e to the i theta power is read aloud in these ways:

a. When reading it straight through, "e to the i theta power"

b. When reading it character by character from the beginning to the end, "e, power i, theta, end power"

c. When reading it character by character from end to beginning, "power, theta, i, left super, e"

Subscript:

x with the subscript n is read aloud in these ways:

a. When reading it straight through, " x sub n" 

b. When reading it character by character from beginning to end, "x, sub n, end sub."

c. When reading it character by character from end to beginning, "sub, n, left sub, x"

Here, "left sub" indicates a subscript area on the left hand side of x. This area is skipped in the case b.  If there were letters in this area, they would be read with the rising intonation before the base character in the case a.

Fraction:

A fraction, a+b over c is read aloud in the following ways:

a. When reading it straight through, "frac a+b over c frac end"

b. When reading it character by character from beginning to end, "frac, numerator a, plus b, end numerator, denominator c, end denominator"

c. When reading it character by character from end to beginning, "denominator, c, numerator, b, plus, a, frac"

Radical:

The square root of 2 is read aloud in these ways:

a. When reading it straight through, "square root 2 radical end"

b. When reading it character by character from beginning to end, "radical, inside radical 2, end inside radical."

c. When reading it character by character from end to beginning, "inside radical, 2, radical"

The nth root of a is read aloud in the following ways:

a. When reading it straight through, "index n root a radical end"

b. When reading it character by character from beginning to end, "radical, radical index n, end radical index, inside radical a, end inside radical."

c. When reading it character by character from end to the beginning, "inside radical, a, radical index, n, radical"

Special Symbols with Superscript and/or Subscript

A summation from k=1 to n is read aloud in the following ways:.

a. When reading it straight through, "summation from k=1 to n of"

b. When reading it character by character from beginning to end, "summation, under k, =, 1, end under, over n, end over"

  c. When reading it character by character from end to beginning, "over, n, under, 1, =, k, summation"

An integral from a to b is read aloud in the following ways:.

a. When reading it straight through, " integral from a to b of"

b. When reading it character by character from beginning to end, "integral, sub, a, end sub, super, b, end super"

c. When reading it character by character from end to beginning, "super, b, sub, a, integral"

A limit of x approaching 0 is read aloud in the following ways:.

a. When reading it straight through, " limit as x right-pointing Arrow 0 of."

b. When reading it character by character from beginning top to end, "limit, under, x, right-pointing Arrow, 0, end under."

c. When reading it character by character from end to beginning, "under, 0, right-pointing Arrow, x, limit"

Matrix:

A 2 times 2 matrix enclosed with parentheses is read aloud in the following ways:

a. When reading it straight through, "left paren, line of 1 a b, line of 2 c d, right paren"

b. When reading it character by character from beginning to end, "left paren, a, b, new line, c, d, new line, right paren"

The message "new line" indicates a special line break in the array representation.  You can move the cursor not only horizontally but also vertically in the matrix.

4.3 Speech Setting

The "Speech menu" allows users to customize the setting concerning speech output.

4.3.1 Voice Setting

If several kinds of voices were installed in your PC, you could change the default voice for each of a text and math parts by the Speech menu.  You can also change the pitch and the rate of aloud reading.  The volume is supposed to be changed with the system volume control.

You can suppress speech output of "space" and "return" by pressing Ctrl + F8 key.

4.3.2  Math Reading Mode

You can select one of two different types of reading: "Plain Reading" or "Detailed Reading" modes. In the "Detailed Reading" mode, all of the character's attributes such as "capital" are read aloud. Pressing Ctrl + F5 key switches these two modes, or you can also change the mode in the "Speech" menu.  Even in the "Plain Reading" mode, you can hear the detailed reading of each character at the cursor position by pressing Ctrl + Alt + H.
Remark:

Using this shortcut, you can also check the font style such as bold, italic.  Incidentally in math expressions all alphanumeric letters are math italic.
If the item "Read pull-down menu list box" is not checked, ChattyInfty would not read symbol names listed in the Context menu. 

4.3.3  Reading Table Editor

Using this editor, you can change the way each symbol is read aloud. The "Default" button cancels all of the customization made by the user. 

Remark:

The definition table is contained in the XML file: Infty2KR.xml.  You can also edit this table directly using any XML editors.

4.3.4  Edit Math Reading

You can edit how to read math syntaxes are read aloud from beginning to end (not character-by-character). The definition file named "MathReading.txt" is located in the ChattyInfty folder. You may edit it by using a text editor. 

4.3.5  Reload Math Reading

While ChattyInfty is running, the new definitions can be reload with this command.  

4.3.6  "Read Aloud" commands
By using these commands, ChattyInfty reads out automatically an indicated part of document without cursor operations.

5.  Function Menu

5.1  Last Reading Bar

"Last Reading Bar" is a one-line window to show a character string of sentence that ChattyInfty has just spoken.  You can move to this window by the Function menu or the Ctrl + F2 key.

5.2  LaTeX Source Bar

"LaTeX Source Bar" is a one-line window to display a character string of LaTeX source that corresponds to the line the cursor is currently located.  You can output the content of this window to a Braille display as will be mentioned later.

6. Setting Menu

6.1  Standard Font Selection

The user can select the font and the size to be used by ChattyInfty.  It will be applied to the entire document.

6.2  Option Setting

Using the "Text/Math Change Shortcut," you can choose one of the following 2 ways to switch the Text/Math modes: 

  a. Ctrl Key   You can switch the Text/Math modes by pressing the Ctrl key only, 

  b. Ctrl + Space key   You can switch the Text/Math modes by pressing a Space key together with the Ctrl key. 

Using the "Backslash Command in Text mode," you can choose the role of backslash key in the text mode.  It could be either the symbol of backslash itself or the prefix of LaTeX commands.

Using "Cursor Order in fraction," you can if cursor will move first to the numerator or the denominator.  

When the "Space Mark" for "Text mode space," "Math mode space" or TeX mode space are checked, spaces will be marked in color so the reader will know their location.  

If "Ctrl + Up/Down to Super" were checked, Ctrl + the Up Arrow key would be a shortcut to move the cursor to the superscript position.  Pressing the Up Arrow key alone would simply move the cursor to the previous line.

6.3  Convert Options

6.3.1  Import Group

In this group, you can choose the formats to be imported to ChattyInfty.  Only the checked items will appear in the Import command in the File Menu. 

The choices are

  a. LaTeX Source Import - a LaTeX formatted file can be converted IML format and be loaded to ChattyInfty. A LaTeX command that ChattyInfty can not convert is imported as in TeX mode. 

  b. OCR-file(KML) Import - a recognition result file of ChattyInfty, KML file, can be loaded to ChattyInfty. 

  c.  MathML File Import (grayed out???)

  6.3.2  OCR Import Group

In this group, you can choose sources which can be recognized by ChattyInfty and set some parameters for the recognition. 

  a. Import from Scanner   You can recognize documents by ChattyInfty via a scanner. 

  b. Import from Image File   You can recognize documents as page image files. 

These items appear in the Import command of File menu if you checked them. 

  c. Delete KML after OCR   ChattyInfty saves recognition results in a KML file. 

If you check this option, ChattyInfty deletes the KML file after recognition. 

  d. Include Image Areas   ChattyInfty saves images included by a recognized document in a KML file. 

6.3.3  Export Group

In this group, you can choose some kinds of formats to be converted from edited documents by ChattyInfty.  Only checked items appear in the Export]command of File menu. 

  a. LaTeX Output   An edited document can be saved in LaTeX format. 

  b. HTML Output   An edited document can be saved in HTML and each mathematical expression will be saved as an image file. 

  c. MathML Output   An edited document can be saved in MathML. 

  d. Human Readable TeX Output   An edited document can be saved in Human Readable TeX (HR-TeX). In the HR-TeX, mathematical expressions are described in LaTeX format, but some LaTeX commands that are not needed to describe context of a document (e.g. environmental commands, layout comments, etc.) are omitted. 

  e. Karlsruhe AMS-notation Output - Karlsruhe AMS (ASCII Mathematik Schrift) is developed in Karlsruhe University to describe mathematical expressions only using ASCII characters.

6.4 Math Level

The math levels are:  

  Junior high school math,

  Senior high school math,

  University math,

  Professional math.

Since ChattyInfty provides many symbols for highly technical materials, setting the correct level limits the choices of symbols.  

7.  Using ChattyInfty with Other Screen Readers

7.1  Using ChattyInfty with JAWS

Since the current version of ChattyInfty could read out all the contents and menus, you might not need to utilize another screen reader with ChattyInfty if you hoped math access with speech output only.  However, if you would like to make use of a Braille display, you would have to use a screen reader such as JAWS along with ChattyInfty since it has no function to output Braille directly.  When ChattyInfty is used with JAWS, some conflicts between their speech outputs will take place.

In order to avoid the speech conflictions, we prepared JAWS's script files for ChattyInfty.  If necessary, please install them in the following manner.

Put three script files included in the package of ChattyInfty into the setting folder of JAWS for each local language.  For instance, the setting folder in English OS might be:


C:\Documents and Settings\"your account"\Application Data\Freedom Scientific\JAWS\7.10\settings\ENG\.

7.2  Output to Braille Display

The script files for ChattyInfty not only suppress JAWS's speech but also send the content of TeX-source-bar window to the Braille display via JAWS.  In order to use this function, you need to open this window by the Function menu.

Remark:

The LaTeX Source Bar only shows a character string of the LaTeX source that corresponds to the line the cursor is currently located.  The position of cursor is not indicated.  Furthermore, you may need to tune the setting of your Braille display to show the content correctly.

8. Operations concerning LaTeX

8.1  About TeX Environment

The document created by ChattyInfty can be exported into LaTeX format. You can compile it and preview the DVI file on ChattyInfty. Furthermore, the DVI file can be converted into PS (PostScript) file or PDF (Adobe Portable Document Format) file. However, to use these functions (except for exporting LaTeX), you must install TeX environment in your PC. You can download an archive file of LaTeX installer package including all the necessary tools to use LaTeX functions in ChattyInfty from the site: http://www.inftyproject.org/en/download.html

8.2  Description of Operations concerning LaTeX

8.2.1  Exporting LaTeX

You can export the document created by ChattyInfty into LaTeX format by selecting the item "LaTeX Output" from the TeX menu.

8.2.2  Editing Source

You can edit the LaTeX source file just created, by selecting the item "Edit Source" from the TeX menu.

8.2.3  Compiling LaTeX Source

You can compile the LaTeX source file by selecting the item "Compile" from the TeX menu.

8.2.4  Previewing DVI File

You can preview the DVI file by selecting the item "Show DVI File" from the TeX menu.

8.2.5  Opening Log File

You can open the LOG file output after LaTeX compiling by selecting the item "Show LOG File" from the TeX menu.

8.2.6  Converting to PS

You can convert the DVI file to PostScript(PS) file by selecting the item "DVI -> PS Convert" from the TeX menu.

8.2.7  Converting to PDF

You can convert the DVI file to PDF file by selecting the item "DVI -> PDF Convert" from the TeX menu.

8.3 Setting concerning LaTeX Output

8.3.1 Preamble Setting 

By selecting the item "Preamble" from the TeX menu, the dialog box "Setting TeX" appears. You can design the preamble to be output in the heading of LaTeX source file. The preamble design can also be read from existing LaTeX source in user's PC, by clicking the "Input from" button in the dialog box.

8.3.1 Treatment of Spaces and Line Feeds

You must select one of the two modes in the conversion of ChattyInfty source to LaTeX source. One is "quasi-WYSIWYG mode" that converts each line feed in the ChattyInfty source file to a double line feed in the LaTeX source file, and outputs so that the screen and the printing are almost the same. You can select this mode by clicking the check box in the dialog box opened by selecting the item "LaTeX Output Option" from the TeX menu. The other one is "LaTeX source editing mode" that outputs spaces and line feeds in the ChattyInfty source file to LaTeX source file without changing. Please see the next subsection about the control of spacing and line feeds in "LaTeX source editing mode".

8.4 Input Guide for LaTeX Source Editing Mode

In writing a source file using LaTeX, the treatment of spaces and line feeds are different from writing text with usual word processors. The following hints will help avoid problems:

8.4.1 Treatment of Spaces

In LaTeX, the spaces are automatically treated, and the spaces in the source file are ignored when printing. If you want to place blank intentionally, you must specify it explicitly in the source file as follows:

  a. Space in horizontal direction: \+space, \quad, \hspace{1.5cm}, etc.

  b. Space in vertical direction: \bigskip, \medskip, \vspace{3cm} , etc.

  8.4.2 Line Feeds

Line feeds at the end of each line in LaTeX source files are ignored when printing. If you need to start a new line, insert a blank line at the position where you want to do so. Another way is to use line feed command, "\par".  Since these two line feeds mean the end of a paragraph, the line following them is automatically indented.  If you want to change a line without the indent, use "\\" command instead of "\par or the blank line. You may also use "\noindent" command.

Note that users should adopt the above two rules with "LaTeX source editing mode". ChattyInfty displays the formula, bold/Italic, centering, etc on the screen in the print style as much as possible. However, to ensure that you can write freely without sacrificing LaTeX's power for expressions, the controls of spacing and line feeds in "LaTeX source editing mode" are defined according to the above two rules. 

8.4.3 Half size Spacing

You can insert a half size space by Shift + space. The half size space in "LaTeX source editing mode" is converted to "\ " in LaTeX source file.     

8.4.4 Formulas and Text

Each mathematical formula written within other texts is output between the single $ commands: $ ... $ in LaTeX source file. On the other hand, if you center the line which consists only of mathematical formula, it is output between the double $ commands: $$ ... $$ as the display style formula in LaTeX. The centered line of formula is treated as independent one when you start the new line with Enter key; however, if you use Shift + Enter instead, successive lines are treated as one display style formula.

8.5 Enhanced Command Input

ChattyInfty provides "TeX Mode" in both of "quasi-WYSIWYG mode" and "LaTeX source editing mode" so that you can use other symbols not available in ChattyInfty.  Many other convenient commands of LaTeX such as \section, \subsection, \label, \begin{figure}, \begin{enumerate}, etc. are also provided.  By selecting "TeX Mode" from the Format menu, you get into "TeX Mode". Then, keyboard input strings are not converted automatically even if they include \ sign; they are displayed as strings of TeX commands. The characters input in "TeX Mode" in Text area is displayed in red (default). The characters input in "TeX mode" in Math area is displayed in brown (default).

9. File Operations

9.1  Available File Formats

The file formats that ChattyInfty can open are: 

  a. XML files especially created by Infty software (*.iml)

You can open IML files by selecting the item "Open" from the File menu. You can save the documents created in ChattyInfty as a special Infty XML file (*.iml) by selecting the item "Save" from the File menu (or Ctrl + S). You can also save the documents created in ChattyInfty as IML file with new filename by selecting the item "Save As" from File menu.

  b. LaTeX Source files (*.tex)

You can open a LaTeX file by selecting the item "Import LaTeX" from "Import" in the File menu.

9.2  Exporting to Other Formats

ChattyInfty provides several output formats for the edited documents. The basic data format of ChattyInfty is XML; they have a file name with the extension ".iml".  The other output formats available in the current version are: LaTeX, HTML, MathML and "Human Readable TeX". 

9.2.1  Exporting to LaTeX

You can export the document created in ChattyInfty into LaTeX format by selecting the item "LaTeX" from "Export" in the File menu (or Shift + Ctrl + T).

9.2.2  Exporting to HTML

You can export the document created in ChattyInfty into HTML format by selecting the item "HTML" from "Export" in the File menu (or Shift + Ctrl + H). Mathematical expressions will be inserted as PNG format images.

9.2.3 Exporting to MathML

You can export the document created in ChattyInfty into MathML format (*.xml) by selecting the item "MathML" from "Export" in the File menu (or Shift + Ctrl + L). Mathematical expressions will be inserted not as images but as MathML.

9.2.4  Exporting to Human Readable TeX

You can export the document created in ChattyInfty into "Human Readable TeX" format (*.txt), which is an alternative simpler syntax for people with print disabilities who are familiar with LaTeX.  Export by selecting the item "Human Readable TeX" from "Export" in the File menu (or Shift + Ctrl + X). 

9.2.5  Exporting to Spoken Text
You can export the document created in ChattyInfty into a text file consisting of a spoken text by performing "Spoken Text" command from "Export" in the File menu.  Since, inn this file, all math expressions are replaced with their word descriptions, you can read it with another screen reader.
9.2.6  Other Import/Export File Format

As for the Import/Export in other file formats, see the item "Convert Option" in the Setting menu.

9.3 Page Frame

You can select one of the two modes to display edited documents, Page Frame: ON/OFF. The page frame is consistent with the actual printout created by printing from ChattyInfty without using LaTeX. If you set Page Frame: ON then "LaTeX Output Option" will be "quasi-WYSIWYG mode" automatically. If Page Frame is OFF, it will be in "LaTeX source editing mode".

Remark:

When the Page Frame is off, you cannot print out the entire document.  The page jump command, the Ctrl + Shift + G is not available either.

9.4 Page Setting and Printing

You can set the page property by selecting the item "Page Setup" from the File]menu. The standard page properties in ChattyInfty are as follows: 

    a. Paper size: A4, A5 and Japanese-own standard sizes, B4 (10 by 14 inches) and B5 (7 by 10 inches)

    b. orientation: Vertical, Horizontal

    c. Margin

    d. Page layout: Single or Two columns, Output page numbers

    e. Page title

If the document contains 2 or more pages, page numbers will be shown in the footer automatically. You can also select no-page-number output mode. 

9.5  Control of Page Break

If Page Frame is ON, by pressing Ctrl + Enter, the cursor will move to the top of next page. When there are two columns, cursor moves to the top of the next column. 

10.  Other Menus

10.1  Edit Menu

From the Edit menu, operations listed below are available:

* Undo: (U)  [or Ctrl + Z]


It undoes up to 10 steps back to the previous status.

* Redo:  [or Ctrl + Y]

It redoes the undone steps.

* Cut: (T) [or Ctrl + X]

It cuts the selected range and holds that item on the clipboard.

* Copy: (C) [or Ctrl + C]

It copies the selected range and holds that item on the clipboard.

* Paste: (P) [or Ctrl + V]

It pastes the item cut or copied. You can also paste a character string copied in the ChattyInfty file (*.iml) to other applications through Windows clipboard. If it includes mathematical expressions, they will be pasted in the LaTeX format. You can paste a character string written by other text editor with math expressions in the LaTeX format to ChattyInfty files.

* Delete: (D) [ or Del]

It deletes the selected range.  

NOTE:  The above six commands can be also performed from the Context menu that pops up by pressing the Application key on the keyboard or the right click.

* Select All:     [or Ctrl + A]

It selects all the content in the currently opened document.

* Insert Image (figures, charts and images):

It inserts a figure, a chart or other images as image into the iml file. In order to insert images, you have to prepare image files in one of the following formats: 

.bmp, .jpeg (.jpg), .png and .tif (without lzw compression).

If you select "Image Position" from the Context menu, you can select the image layout and its size. Note that it is not possible to insert images into super/subscript positions.

* Copy of math expressions as Images:     [or Ctrl + Shift + C]

Using this command, you can paste math expressions made in ChattyInfty to other software in alternative form other than LaTeX. Since math expressions written in ChattyInfty can be copied as images into the clipboard of Windows, they can be pasted into various Windows applications such as Microsoft Word, PowerPoint and so on. 

10.2  Format Menu

From the Format menu, operations listed below are available.

* Text mode (T)

* Math mode (M)

* TeX mode (X)

* Footnote mark,  When entering a footer text in a scientific document, select whether it should be superscript or subscript within an original line height (level).  

The status bar shows the mode currently selected. You can also switch the Text/Math mode to each other by pressing Ctrl + Space key.

* Font Style

Italic and Bold commands emphasize the selected range with each style. Characters that can have Italic or Bold styles are limited to Numeric, Roman, German, Latin and Latin2. Pressing Ctrl + I key changes the style to Italic, and Ctrl + B key changes it to Bold.  You can check out the style of already-entered character by pressing Ctrl + Alt + H.
* Frame line: 

When you want to insert a blank box, enter spaces first, select them and choose "frame line" command; then, the box is entered at that position. Note that these blank boxes are currently incompatible with LaTeX output. 

* Font size:

A standard size is established by the Setting menu. The standard size set here indicates the "Medium" in "font size" in the Format menu (actual size: F3 in the list).  From this standard size, "large" and "ultra large" commands enlarge the size by 2 and 4 points, respectively. "small" and "ultra small" commands reduce it by 2 and 4 points, respectively. These 5 levels in total become the optional font sizes. The font size can be changed with the Format menu. 

When you want to change the font size for the line already entered, move the cursor to the line and select new size from the menu. The same size will be applied to all lines in the paragraph concerned.

Since only one standard size is effective in one file, if you change the setting of standard size in the middle of it, the standard size (Medium:  F3) will be changed for the entire file. 

* Centering, 

Character layout can be changed for paragraphs as a unit by the following commands: Left align, Centering, Right align

10.3 Find Menu

You can Find and Replace character strings not only in the Text mode but also in the Math mode. Commands listed below are available.

* Find in Text     [or F3],

* Replace in Text,

* Find in Formula     [or Ctrl + F3],

* Replace in Formula.

11. Contact Information

Contact information can be found on our web site, 

URL  http://www.sciaccess.net/en/index.html.
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